看板 AndroidDev 關於我們 聯絡資訊
初學者小弟我,在設定AS上面發生了一些問題。 進入了AS後,工具列下面的頁籤上面會顯示Gradle project sync failed。 看下面message告訴我 Could not run build action using Gradle installation'C槽AS目錄裡gradle2.8資料 夾' 我用的是AS1.5.1、gradle 2.8 小弟查詢了stackoverflow試過一些方法 1.安裝SDK Android Support Repository 結果:找不到那個SDK(失敗) 2.在gradle.properties 改變最後一項gradle版本 結果:沒反應(失敗) 3.砍掉使用者.gradle資料夾,然後重開 結果:(失敗) 4.gradle.bulid加入dependencis內容,gradle版本號上+號 結果:(失敗) 5.今天是星期二 結果:失敗 雖然從來沒成功過,依然不減我想要用AS開發的願望,有想過是否因為我用windows的關 係,之前一氣之下在google輸入了Android Studio Sucks,結果看到大部分網上問題OS都 是windows,每次上頭gradle project sync failed 按重試都沒進展(又超久),proxy 也設定了,如今小弟我已經無招可用了,只能問問各位高手,感謝。 -- ※ 發信站: 批踢踢實業坊(ptt.cc), 來自: 101.12.106.157 ※ 文章網址: https://www.ptt.cc/bbs/AndroidDev/M.1456986771.A.4A2.html ※ 編輯: yous421 (101.12.106.157), 03/03/2016 14:36:22 ※ 編輯: yous421 (101.12.106.157), 03/03/2016 14:41:08
ssccg: 我用windows沒遇過這問題 03/03 15:01
ssccg: 你專案設定是用default gradle wrapper? 03/03 15:05
ssccg: 2 gradle.properties 這檔案根本沒有用吧 03/03 15:11
ssccg: 4 如果是指build.gradle,這邊是build tool不是gradle 03/03 15:14
yous421: 我不太清楚 想請教一下當初安裝有設定什麼嗎?我都一路 03/03 15:24
yous421: 按下去 謝謝 03/03 15:24
ssccg: File > Settings > Build...下的Build Tools下的Gradle 03/03 15:27
ssccg: 如果是gradle wrapper應該不會用到另外裝的gradle 03/03 15:33
ssccg: 使用的版本是看gradle\wrapper\gradle-wrapper.properties 03/03 15:37
ssccg: build.gradle裡那個tool的版本現在最新是1.5.0 03/03 15:38
yous421: 剛剛把設定改成default gradle wrapper,不過還是一樣結果 03/03 17:30
yous421: @@ 03/03 17:30
LaPass: 我記得上排選單好像有個什麼 cleanup gradle之類的按鈕, 03/03 20:54
LaPass: 按下去後重新build一次即可。那樣會重抓gradle回來 03/03 20:55
LaPass: File | Invalidate Caches/Restart. 03/03 21:03
LaPass: 這個 03/03 21:03